Project

General

Profile

Actions

Cisco1841/Cisco HWIC-4ESWの使い方

一般論

いわゆるスイッチモジュールであることに注意。つまり、 物理interfaceにIPアドレスは割り振れない

ではどうするかというと、

  1. vlanインタフェイスを作る。
  2. vlanインタフェイスにIPアドレスを割り当てる。
  3. Ethernetインタフェイスを、目的のvlanへ所属させる。

こんな感じ。要はCisco1812j辺りと同じという事か。

interface FastEthernet0/1/0
 switchport access vlan 11
 no ip address
!
interface FastEthernet0/1/1
 switchport access vlan 12
 no ip address
!
interface Vlan11
 ip address 192.168.11.1 255.255.255.0
!
interface Vlan12
 ip address 192.168.12.1 255.255.255.0
!

トランクモード

前の版ではぐだぐだと書いていたのだが、中途半端な事を書くのは良くないと思い直し、ばっさり削除。やはり Ciscoのペイジ を読むのが一番だろう。

具体的な方法は:

interface FastEthernet0/0/1
 switchport mode trunk
end

これが基本となる。 トランクモードに設定された物理ポートに対向するスイッチの物理ポートは、当然トランクモードにする。 …Q-in-Qとかあるけど、それはまた別途の話ということで。

あと、トランクモードに設定したポートを通過するVLANのidは、(当然の事ながら) 制御可能である。 具体的には、こんな感じ。

interface FastEthernet0/0/1
 switchport trunk allowed vlan 1,2,120-500,1002-1005
 switchport mode trunk
 no ip address
!

上記の設定では、VLAN IDとして1,2,120〜500,1002〜1005を付与されたフレームがFa0/0/1を通過できる。

スタッキング

以下、まだ検証してはいないので、そのつもりで。

こちら とか、こちら でも書かれていることですが、一つの筐体で二つのHWIC-4ESWを使う時には注意が必要。要は、 スタック設定というものが必要になる 、とのこと。

具体的にはどうするかというと、

  1. 2つのHWIC-4ESWでそれぞれ1個ずつ、「スタックポート」をセレクトする。
  2. スタックポート同士を、クロスケーブルによって接続してやる。
  3. 以下の設定を投入する。
interface FastEthernet0/0/1
 switchport stacking-partner interface FastEthernet0/1/1
end

interface FastEthernet0/1/1
 switchport stacking-partner interface FastEthernet0/0/1
end

言うまでもなく、上記の場合はFa0/0/1とFa0/1/1をスタックポートとしている。

Cisco純正の資料によればこれで良いはずであるが、英文資料の中には両スタックポートへ switch port mode trunk を入れているものもある。この辺り、ちょっと検証が必要。

あと、この制限はCisco1841だけのものでは ない 。要注意です。

Updated by Tsutomu KIMURA about 8 years ago · 3 revisions locked