Project

General

Profile

Actions

CiscoでIPv6トンネル接続

この時代に敢えてトンネル接続でIPv6通信を行いたいと思う人は、間違いなく固定IPv6アドレスを欲しいと願う人達でしょう。はい、私もその一人です。

OCNのIPv6トンネリング接続サービスの場合

まずはこれだよね…と思ってたらいつの間にか サービスの新規受付が終わっている罠

ということでISPとの契約云々に関する話は省略。以下、実際の設定です。

interface Loopback1
 ip address xxx.xxx.xxx.xxx 255.255.255.255
 ipv6 address 2001:380:649::/128 anycast
 ipv6 address 2001:380:649:1::/64 eui-64
 ipv6 address autoconfig
 ipv6 enable
!
interface Tunnel0
 description IPv6 tunnel(OCN)
 no ip address
 ip mtu 1430
 ipv6 enable
 ipv6 inspect T0_in in
 ipv6 inspect T0_out out
 ipv6 traffic-filter t0_in in
 ipv6 traffic-filter t0_out out
 tunnel source BRI0
 tunnel mode ipv6ip
 tunnel destination xxx.xxx.xxx.xxx
!
interface BRI0
 ip unnumbered Loopback1
 ip access-group bri0_in in
 ip access-group bri0_out out
 ip mtu 1454
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer idle-timeout 0
 dialer string 1492
 dialer-group 1
 ipv6 unnumbered Loopback1
 isdn switch-type ntt
 isdn point-to-point-setup
 ppp authentication chap callin
 ppp chap hostname foo@bar.baz
 ppp chap password 7 ********
 no cdp enable
!

……微妙におかしい気がしないでもないのですが、ひとまずこれで動いています。

tunnelbrokerサービスを使う場合

Hurricane Electric が提供するサービス。これも有名。有名すぎてスピードが遅くなってきたのが泣きどころか?

interface Tunnel3
 description Hurricane Electric IPv6 Tunnel Broker
 no ip address
 ipv6 address 2001:470:23:91::2/64
 ipv6 enable
 ipv6 mtu 1280
 ipv6 inspect T3_in in
 ipv6 inspect T3_out out
 ipv6 traffic-filter T3in-list in
 ipv6 traffic-filter T3out-list out
 tunnel source xxx.xxx.xxx.xxx
 tunnel mode ipv6ip
 tunnel destination xxx.xxx.xxx.xxx
 tunnel path-mtu-discovery
!

tunnel sourceのアドレスはこちらで持っているIPv4アドレスです。MTUはここまで下げることでようやく疎通性が確認できましたので、このままにしています。

Updated by Tsutomu KIMURA over 6 years ago · 5 revisions locked